ELV

Blower Motor Problems | Auto Repair Help

http://www.youfixcars.com/blower-moto… Blower motor problems video highlighting diagnostic procedures for Diy car mechanics. Proper electrical diagnosis of…

24 Comments

  • Impala Chevy

    02 6 Cyl- Blower stopped last week and the auto repair shop replaced it.Now there is a whine when I turn it on, like the motor is revving up, but it whines continuously on every speed. Not really loud, just annoying, as it was silent before, just the fan noise.I took it back the same day, they checked it out and cleaned all around to make sure no leaves anywhere, and it still whines.They say it has to do with it being new, something about brushes. You’ve mentioned bearings, so might that be it?

  • mgaspard0

    Thanks. I did a lil research in the Haynes book and decided to check fuses. I had a 30amp fuse blown. It was the fuse that directly powered the number 5 speed on my fan!

  • mgittelman

    If only high is inoperative then a likely cause could be the high blower relay. I Stress ” Likely” because it could also be a few other things like the blower switch or wiring problem. Electrical problems are capable of throwing wild curve balls at times.

  • mgaspard0

    I have an 03 Chevy Malibu and my fan blower does not work on HIGH only. It works on speeds 1-4 very well. You made an example in this video about the high setting being the only one that would work….what about in my case where high is the only speed that will NOT work? Thank you!

  • Shane Porter

    Hi I am having an issue with a 2000 Mercedes S430. The car was running fine then I decided to check the fuses because of a radio issue, now the car will not start or attempt to but my cooling fan runs extremely too fast. The car still has power but will not start, any help here sir?

  • mgittelman

    Yes Glen I would suspect the high blower relay in your case. Not sure where it’s located on your vehicle but I would not expect it to be near the resistor block. More likely in an under-hood relay center or under the dash? Note that some GM cars have 2 fuses for the blower so check both of those. It could also be the blower switch or wiring problem but the high relay is more likely.

  • Glen L

    Mark I have the opposite trouble on my 2000 impala. It run on the all 3 lower speed but no the high. By your diagram i think it would be the “blower motor relay high” but i dont think my car has one. i already have replaced the blower motor resistor. Think the relay would be in with it. Did i get a bad new part?  Please Help and Thank you in advance!

  • mgittelman

    Jerry Z: The way you describe your problem it sounds like there is a problem with the blend door motor. This is what controls where the air exits from. The Buick dealer has a special tool for diagnosing and recalibrating the blend door motors. This is needed after replacing the control head I think?

  • Jerry z

    I have a 2001 Century and the right side on the AC control panel ..does not do anything no matter where you set it the air comes out of all the vents the same..I replaced the whole Heater/ AC panel and the same thing happens…Can anyone one HELP ? I can’t find any info…..jerry (non climate control system)
    (non Climate control)

  • kevin cantrell

    Did you ever solve your blower motor issue? I have a similar condition except that my fan speed changes on it’s own. seems to downshift when driving faster, never goes off but goes to low and all positions in between. Any suggestions?

  • mgittelman

    daryl I put together a video that tackles your question as this issue comes up quite often. I will add a link to it in the description or you can go to my channel and it will be the most recent video.

  • daryl jake

    hi I have a e46 bmw and I have problem on my blower motor, it doest stop runnin even if I turn the engine off. so everytime I leave the car I need to take the negative battery off. can anyone help me please?

  • sagarika wanamali

    My classmates laughed when I told them I would melt fat with Fat Blast Blueprint, but then they saw the results. Google Fat Blast Blueprint to see their reaction. (You should see their shock!)

  • IMMORTALDIO

    Thank you for the upload , and sharing the information on this motor , and transistor . I now understand a little more on how the power is delivered to the motor , and how it is regulated by the transistor. , and why full speed douse not need to filter by the transistor. I also understand some of the diagnostics on possible failing.

  • sayreakarylm

    Are you satisfied with the pricing of your current motor insurance? Might you be interested about knowing just how you may well cut tons of cash each month? Read our free web page today and begin keeping cash on automobile insurance!
    FreeAutoInsuranceSecrets.com

  • VICTOR TSINNIJINNIE

    HI, I HAVE A 1999 PLYMOUTH BREEZE AND I REPLACE MY BLOWER MOTOR RESISTOR. BUT AGAIN IT WENT OUT BY 4 TO 5 HOURS THE SAME DAY. DESPARTED NEED HELP WITH THIS. I TOOK THE MOTOR OUT AND IT DON’T SPIN FREELY. WHAT WOULD BE THE PROBLEM. NEW HEATER MOTOR AND I GOT THE VEHICLE USED FROM A FRIEND.

  • mgittelman

    Donna: I recommend you find a wiring diagram for this car. Some Chrysler’s have a blower relay. A stuck applied relay can cause the situation you described.

  • Donna Reed

    Here is one for you Doc ! 2004 Chrysler is what this is all about. Blower never shuts off. Changed filter for A/C intake. R/R 3 resistors . Checked all fuses. Tore apart the HVAC control panel and tested all wires, were fine. Shut off control panel and blower still runs even with the car off sometimes. Noticed my ignition switch is acting funny. When the off button is applied the blower goes to either A/C or re-circulate. So just how many fuses does a HVAC control panel have?No speed controls.

  • Doug Davis

    I have a 1996 2.2 VTEC Accord with a weak-blowing AC system. I read this was a common problem on this generation of the accord, but found no legit solution. The setting would be on “4” but it feels like it’s on “3”
    Would it be the blower motor?

  • doc ice

    I had reblaced the blower actuator/blend door resistor as needed blower was working but I don’t get air blowing towards me what should I do about this

  • mgittelman

    I replaced a vacuum storage ball on a 98 Cherokee (not grand) with a straight six and it was on the p/side fender well toward the firewall if I remember correctly? I don’t know on the diagram I’m not even sure if it’s in all-data. The factory dealer manual might be the only place unless someone has made it available online? You can check in the Jeep forums.

Leave a Reply

Your email address will not be published. Required fields are marked *

Powered by Yahoo! Answers